Update Amazon Kindle or lose Internet connectivity

Amazon has warned old Kindle users to update their devices by 22 March or face connectivity issues

Tags: Amazon.com Incorporated
  • E-Mail
Update Amazon Kindle or lose Internet connectivity Without an Internet connection, users will no longer be able to access the Kindle Store or sync the device to the cloud, which means users will be unable to download new books (Getty)
By  Aasha Bodhani Published  March 21, 2016

Amazon has warned owners who have the original Kindle Paperwhite and every Kindle made before 2012, must update their software by 22 March or lose Internet connectivity.

Without an Internet connection, users will no longer be able to access the Kindle Store or sync the device to the cloud, which means users will be unable to download new books. According to Amazon, the update is required to ensure the Kindle remains compliant with industry web standards.

If users do not update by 22 March, they will receive the following message from Amazon:

"Your Kindle is unable to connect at this time. Please make sure you are within wireless range and try again. If the problem persists, please restart your Kindle from the Menu in Settings and try again."

Kindles which are in regular use, will most likely update automatically via WiFi, but for those which have been turned off or out of battery for a while, Amazon prompts users to charge it up and sync and Check for Items. Once the update has been successful, users will find a confirmation letter called "03-2016 Successful Update" on the device.

The devices which require an update are, Kindle 1st Generation (2007), Kindle 2nd Generation (2009), Kindle DX 2nd Generation (2009), Kindle Keyboard 3rd Generation (2010), Kindle 4th Generation (2011), Kindle 5th Generation (2012), Kindle Touch 4th Generation (2011) and Kindle Paperwhite 5th Generation (2012).

If users miss the update deadline, they will have to manually download and install it.

Add a Comment

Your display name This field is mandatory

Your e-mail address This field is mandatory (Your e-mail address won't be published)

Security code